PS3 Multiman 4.60

PS3 Multiman 4.60 available, support for 4.60 CFW!

This wasn’t enough to get your latest games working?
Here’s the PS3 4.60 Spoof enabler

Great work guys… although not sure what they’re actually used for? 😉

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.